Skip to content
Advertisements

VMware Client Integration Plug-In not Working in Chrome? – Round 2

Now that Google has released version 45 of Chrome the NPAPI enable-trick that I showed you a couple of months ago has finally stopped working. The good news is that VMware has fixed the whole issue in vCenter 6.0 Update 1. So as long as you update, you’ll be fine. And if you want to continue using vCenter 6.0, they have released a new Client Integration Plugin (CIP) that works with vCenter 6.0.

But, the bad news is that the new CIP doesn’t fix compatibility with older versions of vCenter, for example 5.1 and 5.5, which I’d wager is still a sizable part of the VMware vSphere installations out there. There’s a fix promised coming within a short while, but since Google has been threatening with retiring NPAPI for 2 years now, I would not hold my breath for a quick resolution.

The best course of action at the moment is to switch browsers if you need the special features provided by the CIP, provided that you haven’t updated to vCenter 6.0 already. Keep in mind that the CIP also has some issues with Mozilla Firefox starting from version 39 onwards, but they can be fixed by flipping some flags.

VMware’s KB article on the Chrome v.45 issue with links to the new CIP for vCenter 6.0 users. 

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: